====== Cisco 2960 configuration notes ======
Easiest way to connect is to use the console port and minicom. Configure minicom __/etc/minicom/minirc.dfl__ as follow:
# Machine-generated file - use "minicom -s" to change parameters.
pu port /dev/ttyS0
pu baudrate 9600
pu bits 8
pu parity N
pu stopbits 1
The launch the minicom command to get a terminal on the switch.
# minicom
Welcome to minicom 2.4
OPTIONS: I18n
Compiled on Sep 5 2010, 08:31:32.
Port /dev/ttyS0
Press CTRL-A Z for help on special keys
cisco-home>enable
Password:
cisco-home# sh int
Vlan1 is up, line protocol is up
Hardware is EtherSVI, address is 001b.8f48.2cc0 (bia 001b.8f48.2cc0)
Internet address is 192.168.1.254/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
.....
Become root using __enable__ and the admin password.
A few commands:
* //show interface// (//sh int//) displays the status of all interfaces
* //sh int gigabitEthernet0/27// displays a specific interface
* //sh ru// displays the running config
* //conf terminal// (//conf t//) switches to configuration mode
* //int gigabitEthernet0/27// configures this interface
* //switchport mode trunk// changes the interface to trunk mode
* //switchport trunk allowed vlan 1,2,4-4094// lists the allowed VLANs on that trunk interface
* //switchport access vlan 3// puts the whole interface into VLAN 3
* //switchport trunk allowed vlan 3// allow only vlan 3 on this interface
* //wr mem// saves the running configuration permanently
A few more, see doc:
* //spanning-tree portfast//
* //spanning-tree bpduguard enable//
* //spanning-tree guard root//
Example of interface configuration:
Trunk interface
interface GigabitEthernet0/27
description Ramiel trunk LAN interface
switchport trunk allowed vlan 1,2,4-4094
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root
Access interface:
interface GigabitEthernet0/13
description Office 1
switchport access vlan 3
switchport trunk allowed vlan 3
spanning-tree portfast
spanning-tree bpduguard enable
spanning-tree guard root